What Bibles will work with my version of EasyWorship?

Modified on: Wed, 11 Jul, 2018 at 4:52 PM


EasyWorship has lots of Bible translations available.  There are some newer ones that have been added with newer versions of EasyWorship that won't work in older versions of EasyWorship.

To find out which Bibles work in the different versions of EasyWorship, check out our Bible Plug-Ins page.


Can't find what you need? Let's have a conversation about it in our community.

Start a new discussion.

Log in or sign up to start a new discussion.